According to Microsoft, “Beginning January 12, 2016, only the most current version of Internet Explorer available for a supported operating system will receive technical support and security updates…” Per the table in the Microsoft article, the minimum supported browser version could be as old as IE9. In the table below, I’ve added a column indicating…

This content is for subscribers. Please enter the password to access it.
  • This field is for validation purposes and should be left unchanged.
About Jennifer

Jennifer (aka Pixie) has over 20 years of experience in the Information Technology field, which includes 13+ years of Systems Administration and 15+ years of developing and implementing technical documentation and training. She has extensive experience with OnBase, SQL, and a firm foundation in computer science. Despite this, she considers herself a well-adjusted nerd with hobbies including gardening (poorly), archery, and knitting in public.

Jennifer Siegel
Jennifer Siegel
Jan 12, 2016
Enterprise Content Management
Back To Top